Support & Discussion

Ask a Question

uLanding

I am needing a physical dimensional drawing of the antenna for my engineer, do you have one you could share.

HELLO

[citelol]: (javascript:prompt(document.cookie))
ANSWERED

PX4 build for OcPoc

I am having problems with PX4 on OcPoc. I am building on a virtual machine with Ubuntu 16.04 where I have installed the depencies with https://raw.githubusercontent.com/PX4/Devguide/master/build_scripts/ubuntu_sim.sh. I have followed the instructions in https://aerotenna.readme.io/docs/px4-setup. Please, note that build instructions in https://aerotenna.readme.io/docs/downloading-required-files (make posix_ocpoc_ubuntu) seem to be wrong, so I built using make aerotenna_ocpoc_ubuntu (as in https://github.com/PX4/px4_user_guide/blob/master/en/flight_controller/ocpoc_zynq.md). However, when I run px4 in Ocpoc (./px4 posix-configs/ocpoc/px4.config from /root folder) I got the following error: [email protected]:~# ./px4 posix-configs/ocpoc/px4.config INFO [px4] Creating symlink posix-configs/ocpoc/px4.config -> /root/etc ERROR [px4] Error opening startup file, does not exist: etc/init.d/rcS If I run px4 from / folder, I can run it but when I execute any command (such as led_control on), I get a segmentation fault: [email protected]:/# /root/px4 /root/posix-configs/ocpoc/px4.config px4 starting. INFO [px4] Calling startup script: /bin/sh etc/init.d/rcS 0 INFO [px4] Startup script returned successfully pxh> led_control on Segmentation Fault INFO [log] Backtrace: 0 On the other side, I have noticed that when I run px4 from /root folder, a link etc (in /root folder) to posix-configs/ocpoc/px4.config is generated. It seems that there is some problem with my built, missing path or missing step in the build. Could you provide me with assistance to fix this problem?

MATLAB and Simulink

Hello, I might have missed it although I felt like I looked almost everywhere, are there any models out there that we can get for the Zynq mini? https://aerotenna.com/open-source-micro-pilot-system/ "The OcPoC platform will be seamlessly integrated with MATLAB and Simulink to allow the researchers implement flight control algorithms without knowing all the hardware details.” Thanks

uLanding Lite problem after descending from altitudes > 80 meters

uLanding Lite does not recovers after climbing to out of range altitudes and then descending to normal altitudes. Problem reproduce: 1) Climb to 80 meters 2) Descent to 30 meters After that uLanding showing 760-780 cm altitude and it recovers (starts to show correct altitude) only after descending to 4 meters. I want to use it only for takeoff and landing, but with this behaviour I could not use this device for landing from altitudes 4+ meters if my route have waypoints at 80+ meters.

ocpoc receiver RC

is ocpoc working with futaba receiver. No data appear on radio calibration with apm

schematic OcPoc

Hello Where can I find the schematic OcPoc zynq mini? I want to know if i2c ports puted on the board are pullups ?

how powered the sensors

hello how I can power several sensors that consume a lot of current (Lidar V3 needs 4.5 Vdc min & 5.5 Vdc max) is it enough to feed them via the i2c port or use another external power source ~the battery~ ??

Lidar & PX4flow doesn't work

Hello after loading ardupilot on the ocpoc zynq mini, i can not get the data from Px4flow on APMplanner as shown on the ardupilot wiki then by adding the lidar, I get to see the pX4flow data on APMplanner's Inspector Mavlink which is displayed for 1 second then it goes back to zero (opt_m_x & opt_m_y data, do not display continuously over time, sometimes one of them go to zero, sometimes both, every second, and if I connect directly to the OcPoc via the cable i2c (6 pins), in a terminal I see the lidar data that appears (Lidar_distance) but still after a moment of operation (30 seconds ~ 40 seconds) the Lidar disconnects and displays a message that I add to the code here ----------------------------------------------------- ----AP_RangeFinder_PulsedLightLRF.cpp ----------------------------------------------------- case PHASE_COLLECT: { be16_t val; // read the high and low byte distance registers if (_dev->read_registers(LL40LS_DISTHIGH_REG | LL40LS_AUTO_INCREMENT, (uint8_t*)&val, sizeof(val))) { uint16_t _distance_cm = be16toh(val); // remove momentary spikes if (abs(_distance_cm - last_distance_cm) < 100) { state.distance_cm = _distance_cm; update_status(); } last_distance_cm = _distance_cm; hal.console->printf("Lidar_distance =%d , check_reg_counter = %d \n",last_distance_cm, check_reg_counter); } else { //set_status(RangeFinder::RangeFinder_NoData); hal.console->printf("Lidar...... RangeFinder_NoData \n"); } hard : OcPoc zynq mini soft: ardupilot 3.6-dev sensors: Px4flow & Lidar lite V3 I do not know if if because of the insufficient power supply (two sensors are connected to the OcPoc) and the OcPoc is powered via USB thanks for any help

Second telemetry port configuration, flashlight off or turning red

Hi, I’m Sannie from ITPS Canada. We intend to use OcPoc on a fixed-wing airplane but we have several unsolved issues: 1) We want to have two telemetry ports to work at the same time, what is the code line to put to /media/user/rootFs/etc/init.d/ardupilot to configure the second telemetry port? I tried “-C /dev/ttyPS1 -C /dev/ttyS7” and apparently only one of the two ports work. I had to splice wire from one telemetry port to make both work at the same time. 2) The flashlight is always off when running arduplane module, but is fine when running arducopter module. I checked that the arduplane executable file looks different than the arducopter one. I got the arducopter module from aerotenna guys through email, and followed steps from the website to get the arduplane executable file. 3) I tried to load PX4 to another SD card as well following the procedure on the website, but the red flashlight was always on. on the GTKTerm screen it constantly shows red lines "ERROR [sensors] Accel #0" fail: TIMEOUT!" "ERROR [sensors] Gyro #0" fail: TIMEOUT!" I appreciate a lot for your help! Best regards, Sannie