Aerotenna User and Developer Hub

Aerotenna User and Developer Hub

Welcome to the Aerotenna User and Developer Hub. Here you'll find guides, manuals, tutorials, and Frequently Asked Questions to help you get started with using OcPoC and μSensing radars, as well as support and discussions if you get stuck. Welcome!

Get Started
Ask A Question

Questions

uLanding Issues with Arduplane 3.8.0

Posted by Evan Williams 3 months ago

All,

My goal is to use the Aerotenna uLanding-C1 for the purpose of maintaining AGL and improving landing performance.

Current Configuration:
Pixhawk 2.1: ArduPlane V3.8.0
GCS: Mission Planner 1.3.49 build 1.1.6410.20232
Altimeter: Aerotenna uLanding-C1 (Serial)

I have the uLanding connected to Serial4 (GPS2) of the Pixhawk 2.1.
SERIAL4_PROTOCOL: 12 (uLanding Parameter value)
SERIAL4_BAUD: 115 (uLanding default Baud Rate)

The only parameter I have changed regarding the range-finder functionality is:
RNGFND_TYPE: 11 (uLanding Parameter value)
I have tried adjusting various values related to the upper and lower bounds, but none have seemed to affect readout. See below.

Unexpected Behavior:
Upon connecting Mission Planner to the Pixhawk, SonarRange reads "0". If I move the altimeter around, 1-3 three similar windows open (??), and the SonarRange value is populated. In most cases, a value of 6.35 (cm) is displayed regardless of orientation and obstructions before the altimeter. On occasion, sporadic (erroneous) values are displayed.

Debugging:
I have used the provided python scripts to manually read out serial data from the uLanding - the values roughly correspond to appropriate distances, though I've considerable concern regarding the consistency of the data. The distances have a considerable number of outliers in the positive direction.

Side Question:
Has anyone implemented uLanding variants with a CAN/I2C option in Ardupilot?

I was hoping someone with a similar configuration utilizing the uLanding might give advice on the proper configuration (parameters) or known issues with my configuration.
Current theories:

  • PH2.1 cannot sustain 115 kbaud on Serial4? When I tried lowering to 9600 baud, the value reset itself to 115 kbaud on next startup and connect cycle.
  • Some parameter related to the abundance of laser analog/PWM altimeters is interfering with the value?

See below [Forum Link] for an example of the issue (including mystery window) and a copy of my parameters.

NOTE: This question was originally asked here https://discuss.ardupilot.org/t/aerotenna-ulanding-extensive-issues/20062 as I figured it was a general Ardupilot issue. There, it was recommended that I consult here, as the problem may be driver related.

Loading comments...