Aerotenna User and Developer Hub

Aerotenna User and Developer Hub

Welcome to the Aerotenna User and Developer Hub. Here you'll find guides, manuals, tutorials, and Frequently Asked Questions to help you get started with using OcPoC and μSensing radars, as well as support and discussions if you get stuck. Welcome!

Get Started
Ask A Question

Questions

Second telemetry port configuration, flashlight off or turning red

Posted by Sannie Xu 17 days ago

Hi,

I’m Sannie from ITPS Canada. We intend to use OcPoc on a fixed-wing airplane but we have several unsolved issues:

1) We want to have two telemetry ports to work at the same time, what is the code line to put to /media/user/rootFs/etc/init.d/ardupilot to configure the second telemetry port? I tried “-C /dev/ttyPS1 -C /dev/ttyS7” and apparently only one of the two ports work. I had to splice wire from one telemetry port to make both work at the same time.

2) The flashlight is always off when running arduplane module, but is fine when running arducopter module. I checked that the arduplane executable file looks different than the arducopter one. I got the arducopter module from aerotenna guys through email, and followed steps from the website to get the arduplane executable file.

3) I tried to load PX4 to another SD card as well following the procedure on the website, but the red flashlight was always on. on the GTKTerm screen it constantly shows red lines "ERROR [sensors] Accel #0" fail: TIMEOUT!" "ERROR [sensors] Gyro #0" fail: TIMEOUT!"

I appreciate a lot for your help!

Best regards,
Sannie

Loading comments...